Failed to Create Order Cycle

I am just learning to use the OFN so that I can help a local farmer to beta test the OFN USA platform. I am following the user guide, but when I try to create an order cycle I get an error “Failed to Create Order Cycle.” I have a payment method and delivery method defined. I have created a product and made sure there are some available. My test farm (and my actual farm) is called MS Future Farm. I am a super admin with access to everything on the backend.

Hey. If you could capture a screenshot of the error on New OC page that would help in spotting what could be wrong.

I suspect this might be related to server timeouts. If so that requires sysadmin support.

@MSFutureFarm has been doing some sys admin on the USA server so might be able to fix this. Brandy if you need more detail on Lynne’s suggestion about timeouts you could ask on the ‘deployment’ Slack channel

Don’t know if anything has to do with it, but the “Ready for” date seems strange and in a wrong format?


Just looked into this and the same thing is happening for me. I can’t see why. I don’t think it’s server timeout as it happens almost instantaneously.

I think that format @sigmundpetersen might be because it’s a producer only order cycle?

I’ve created a github issue, and set it at S1 because I think if you can’t create order cycles the platform isn’t useable!

Yep that date format has nothing to do with it. I checked and it’s just a text input field :slight_smile:

1 Like

I copied the date from the Order Cycle start date bu it sounds like it could be anything. Good to know.

I have sysadmin access but won’t be able to get online at home before 5pm central time. If no one can get to it before then, I will check the error logs when I get home.

If that image worked, the delayed job looks to be working and it is not showing any failures. It is SubscriptionConfirmJob, HeartbeatJob and SubscriptionPlacementJob running and completed, followed by 3 jobs processed and 0 jobs failed.

The skylight log shows a configuration error over and over.
Unable to start instrumenter; msg=authentication token required; class=skylight::configuration error

The production log also shows that skylight is unable to start.

@MSFutureFarm sorry to be annoying but there is a github issue now and it would be better to be adding this info there - - could you copy the screenshots over there please? Thanks!

I just did a test OC on the US instance and it works fine. I put a screenshot on the github issue too. You have to have content in both the ‘ready for’ and ‘customer instructions’ fields. It can be just garbage - but you have to have something there. This happens on the Can instance too - you don’t get any error message or anything - but the OC creation just kind of freezes on you, and you get no option to ‘create’. I put this info and my screenshot on github. And maybe this is a deeper problem to be solved. But - it worked for me.

1 Like

@tschumilas @sstead @Rachel does the user guide cover that requirement for text? and/or should they have alerts in the OC to tell people when that is the problem? I suspect so? If the latter is best solution and is definitely not already the case could someone create a wishlist item for it? I think it will likely be a pretty minor thing and ‘good first issue’ but am nervous about jumping too quickly to github . .

[@danielle @MyriamBoure - this seems like another of the not yet handled category of 'not bugs but enhancements but quite minor and likely not needing whole prioritisation / inception process . . ]

the user guide gives clear instructions on what those fields are for, and where they end up appearing to the customer. But I think its easy for a user to overlook them, or think they won’t bother with them, and they they are puzzeled by why the OC won’t save properly. (Indeed, I spent 2 hrs at this one day before I realized that I had to fill in the fields). So really we just need to put a statement in the user guide that says ’ Note - this field needs to be completed for the order cycle to save properly’. for each of the 2 fields. That way if a user runs into problems and re-reads the guide, they’ll figure it out.

I think if you need to go to user guide for basic features we have a UX issue on the platform, so I agree that we would need some wishlist to improve error message and make it clear what to do. For me I would say it is a bug though, a “UX bug” not “tech bug”, it is supposed to work that way but a significant amount of people don’t manage to use the feature, this should qualify as bug to me. It’s bugging on UX, not on tech. @danielle ? Else I agree we will need to iterate on the process maybe to see how to cover those small things… but I would say let’s stick and test current process, and when we have used it then iterate.

You improve the UX, you fix technical bugs. I’ve never used/seen bugs used in the context of UX. Doesn’t mean we can’t…but I would rather call them UX tweaks than bugs #callaspadeaspade :slight_smile:

1 Like

I’ve added ‘required’ to those fields in the user guide. I think the UX used to be better, with the required fields highlighting in red if you tried to Create OC while they were empty. But now they don’t highlight red unless you type something in them and then delete that text.